您的位置: 首页 >>Android安卓资讯 >>Android版本过多问题虽未解决 但你不必为此担忧

Android版本过多问题虽未解决 但你不必为此担忧

发表时间:2011/11/07 17:21 | 0条评论 | 作者 : 尐娃娃Sun

最近有许多关于Android的Fragmentation的文章,相信大家也看过不少。本文中,作者将向你介绍何为Fragmentation,为何Android平台用户无需为此担忧。

什么是Fragmentation?

所谓Fragmentation指的是Android平台的版本过多问题,也就是Android手机或者其它使用Android的设备有不同版本的操作系统,具备不同的特征。

为何Android版本过多问题不可避免?

之所以不可避免,是因为Android是一个如此多样化的操作系统,可以运行在这么多种手机上,有这么多的特征。

比如:Ice Cream Sandwich可通过前端摄像头支持面部解锁功能,HTC的 Desire HD手机在某些方面支持ICS操作系统,但却不支持面部解锁功能,因为手机没有前端摄像头,所以问题就出现了,这让软件开发商相当为难,当他们开发一些新的面部识别应用时,就不得不把Desire HD手机踢出服务手机名单之外,除非他们想利用后端摄像头。

制造商和运营商不给力

如果你想通过运行商来更新系统,那得等到猴年马月啊。一旦Google新出一个Android系统,生产商通常都会先加入自己的软件,比如HTC就会加入 HBOOT,RUU,HTC Sense等。还会加入其它根本不必要的软件。又由于制造商的官僚作风或者内部一些问题,大概需要几个月才能完成更新。

一旦运营商确定下来,运营商也会载入一些无用软件。比如Google明天发行一个版本,那么很可能到2012年你都还用不到这个版本的操作系统。

不用担心,Rooting可以减少Android版本过多问题带给你的不便

对于一些已获得root权限的手机,Android ROMs是个不错的选择,可以避免版本过多问题。一些社区,比如CyanogenMod就促进了许多兼容设备的Android操作系统的升级,如果你的手机没有ICS操作系统,不要着急,我敢打赌,几个月后,你就能享受到那些重量级社区为你提供的便捷服务。

iOS不会遇到这种麻烦?

当然有可能遇到,只是苹果试着把这个隐藏起来,苹果总是缩短更新的周期,蒙混过去。比如我曾经想在iPod Touch上玩一个游戏,但是不能玩,因为我是用的是iOS3.1.1,而游戏要求要iOS 3.1.2.

总结

正如我之前所说的,不必担心Android版本过多,只要你的设备兼容性好,那么就耐心等待,总有像CyanogenMod那样的开发商为你排忧解难,有时可能有些吃力,但事情总会得到解决。你的手机可能不会包含新版Android系统所有的功能,但至少会尽量多。/p>

发表评论

已有0人发表评论
@ 您还能留下2000个脚印

热门评论

最新评论

阴阳师
@ 您还能留下2000个脚印
提示

本游戏安装包为DPK数据包,推荐您使用当乐App安装。

机型匹配

您的手机型号未能匹配成功,请选择以下安装包进行下载。

机型匹配

您的手机型号未能匹配成功,请选择以下安装包进行下载。

机型匹配/下载

下载已成功

知道了

设置机型

您的手机机型是:

请选择手机品牌
请选择手机型号
完成 没找到匹配的机型?

将使用当乐App电脑版为您免费安装

安装流程:

1.下载安装当乐App电脑版

2.选择应用,点击安装到手机

3.连接手机到电脑,自动安装

立即下载当乐APP

将使用当乐App电脑版为您免费安装

还未安装
下载客户端
我已安装
启动客户端安装

登录

登录后才能喜欢哦!

立即登录

关于当乐 | About Downjoy | 联系我们 | 诚聘英才 | 开放平台 | 隐私保护 | 客服中心 | 网站地图

Copyright © 2004- Downjoy. All Rights Reserved. 北京当乐信息技术有限公司 版权所有